Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Nexarius

nexDHD - SG-Craft Stargate Control Program

Recommended Posts

This is my stargate control program for sgcraft called nexDHD :)
 
jOFJQuK.gif
 
How to get it:
link to github


 

pastebin run -f YVqKFnsP

 
Computer requirements:
- CPU T2
- GPU T2
- 12x Screen T2
- HDD T1 (with OpenOS)
- 2x Memory T1.5
- Internet Card - only required for installation and updates
- keyboard - only required for installation
- Redstone Card T2 - optional
- EEPROM (Lua BIOS)
 
features of my program:
- autoclose iris on incoming wormhole (when iriscontrol is turned on)
- autoopen iris if correct IDC is received (iris deactivation code)
- autoclose stargate after X seconds
- show all kinds of stats (local / remote address, state, direction, idc, iris state, energy, ...)
- multiple languages: right now german, english and russian
- displays energy in EU or RF
- displays up to 10 addresses on 1 page (unlimited pages)
- allows dialing from the address list
- check for updates on start
- emit redstone signals (right now for: state not idle, incoming, iris closed, idc accepted, wormhole connected)
- automatically adds new, unkown addresses when there is an open wormhole
- shows the required energy to dial an address (or error if invalid address)
- allows closing of incoming wormholes if its disabled in config AND there is a computer at either end
- automatically sends and receives entire address list on an open wormhole (without the IDC of course) and automatically adds the new addresses
- with touchscreen functionalities
- works with Computronics ColorfulLamps -> red = iris closed, green = idc accepted, yellow = outgoing wormhole, orange = incoming wormhole (priority from left to right)
- logbook with the last connections

Share this post


Link to post
Share on other sites

I'll definitely be using this in my massive underground bunker project (along with a lot of other things).

I still have to get the initial construction done, though. Building twelve floors underground is time consuming, even with WorldEdit. 

Share this post


Link to post
Share on other sites

I seem to have run into some issues when running this. Looks great, but won't run at all.

I have attached a image of the errors it showed.
Versions as follows
OpenComputers: open-computers-1.6.1.11

Components:

  1. T3 CPU
  2. T3 HDD
  3. T3.5 Ram x2
  4. T3 Graphics

Minecraft 1.7.10
Any ideas why this is happening?

2017-01-24_20.05.47.png

Edit: I retryed with t2 components, still no luck. Seems problem is with code.

Share this post


Link to post
Share on other sites

I haven't seen that one because I've been using my already installed computer when I updated OpenComputers to 1.6 which means it still had OpenOS 1.5 on it and OpenComputers 1.6 now has OpenOS 1.6.

They've changed something in OpenOS 1.6 that broke it and figuring out what will be fun because the changelog is the "most helpful thing ever".

Quote

Changed: OpenOS got a major overhaul, in particular term related things, and also a few new built-in programs (payonel). This would deserve a changelog of its own, really...

I will try to fix this.

Share this post


Link to post
Share on other sites

Update to 2.7.1

You can now type "pastebin run YVqKFnsP" to install it but so far I haven't been able to figure out how OpenOS 1.6 messed up autorun so you will have to start the programm manually by typing "stargate" after its installed.

Share this post


Link to post
Share on other sites

well, gave it a test run, it didnt autorun like u said, but it seems to have worked now

i guess this was what it was supposed to show

thnx for the fix

2017-01-25_17.43.52.png

update to last comment
seems the autorun fixed itself every boot after it was installed
after selecting language, it boots straight into it
(only after language was setup after executing file again to open it)

Share this post


Link to post
Share on other sites

hi! Es ist ein schönes Programm doch leider funktioniert es bei mir nicht! Auf dem tier 3 screen ist das bild abnormal klein. Außerdem kann ich nichts anklicken oder kontrollieren . 

Ps: wäre schön wenn du eine Open Modular Turrets integration hinzu bringen könntest .

Open Computers version: 1.5.22.46

Share this post


Link to post
Share on other sites
On 3.2.2017 at 7:12 PM, minechris said:

hi! Es ist ein schönes Programm doch leider funktioniert es bei mir nicht! Auf dem tier 3 screen ist das bild abnormal klein. Außerdem kann ich nichts anklicken oder kontrollieren . 

Ps: wäre schön wenn du eine Open Modular Turrets integration hinzu bringen könntest .

Open Computers version: 1.5.22.46

Open Modular Turrets integration wird wahrscheinlich nicht möglich, weil ich den Mod überhaupt nicht kenne.

Benutz einfach einen T2 screen der hat die selben Funktionen, dann wird es nicht so klein sein. Geht nur der Touchscreen nicht oder hast du es auch mit einem Keyboard versucht?

Kannst du nachschauen ob die Datei /log existiert?

 

Für OpenComputers gibt es schon eine neuere Version 1.6.1.11 und damit wurde OpenOS auf 1.6 geupdated mit starken Veränderungen. Ich musste einige Änderungen vornehmen um es zum laufen zu bekommen und ich hab nicht mehr getestet ob es mit der älteren Version immernoch geht.
Kannst du OpenComputers updaten und dann den Computer komplett neuinstallieren? (Das ist benötigt um von OpenOS 1.5 auf OpenOS 1.6 zu wechseln)

Share this post


Link to post
Share on other sites

das Programm funktioniert in keinster weiße weder Touch noch mit keyboard und das mit dem update wird schwierig weil ich ein vorgefertigtes modpack(FTB Galactic science 1.7.10) spiele wo das mit den neueren versionen meist nicht so prickelnd leuft. Und das mit dem log wird schwierig weil ich davon keine Ahnung habe. 

Share this post


Link to post
Share on other sites
16 hours ago, minechris said:

das Programm funktioniert in keinster weiße weder Touch noch mit keyboard und das mit dem update wird schwierig weil ich ein vorgefertigtes modpack(FTB Galactic science 1.7.10) spiele wo das mit den neueren versionen meist nicht so prickelnd leuft. Und das mit dem log wird schwierig weil ich davon keine Ahnung habe. 

Schreib einfach

view /log

wenns existiert sollte er etwas anzeigen.

 

Hat das Programm ursprünglich funktioniert bis du eine Adresse / Einstellungen geändert hast?

Sieht es bei dir den zumindest so aus wie hier ?

Zeigt es dir etwas an, wenn du das Stargate einfach mit einem stargate controller aktivierst?

 

Kannst du es mal updaten lassen indem du

/stargate/check.lua ja

eingibst?

 

Falls das nicht funktioniert kannst du es komplett löschen und neuinstallieren? Gib dies ein

pastebin run -f YVqKFnsP neu

Solange du mit dem Modpack nicht auf einem Server spielst solltest du das Updaten von OpenComputers problemlos schaffen. (Soweit ich weis sind keine neuen Blöcke oder Rezepte in 1.6 dazugekommen)

 

edit: Kannst du denn sonst überhaupt etwas mit dem Computer machne? Vielleicht bist du nicht in der Liste der zulässigen Benutzer des Computers.
(Serveradmins sind immer erlaubt. Frag also mal einen von denen ob er den PC bedienen kann.)

Share this post


Link to post
Share on other sites

im trying to use this program im currently using OpenComputers-MC1.10.2-1.6.2.7 and SGCraft-1.13.2-mc1.10.2 but once the program detects the stargate it reverts back to the main openOS 1.6.1 screen

Share this post


Link to post
Share on other sites
1 hour ago, tipclaydon said:

im trying to use this program im currently using OpenComputers-MC1.10.2-1.6.2.7 and SGCraft-1.13.2-mc1.10.2 but once the program detects the stargate it reverts back to the main openOS 1.6.1 screen

Is there any kind of error displayed? You might have to start it manually by typing "stargate" (OpenOS doesn't show any error from programs in autorun).

Is there a file called /log ?

Did you reinstall it completely fresh? If not could you do that? "pastebin run -f YVqKFnsP neu"

 

If that doesn't work could you run this "pastebin run -f icKy25PF" and then run this again "pastebin run -f YVqKFnsP neu" .

Share this post


Link to post
Share on other sites

non of these methods seem too work im new to opencomputers but i can not see any log files

no errors show except when i use pastebin run -f YVqKFnsP neu  it states no update location or something

Share this post


Link to post
Share on other sites

Could you update the mods?
I tested it with these versions.

OpenComputers-MC1.7.10-1.6.2.12-universal
SGCraft-1.13.3-mc1.7.10

 

Could you make a short video (or screenshots) of you trying to run it? That would be the easiest method to troubleshot.

Share this post


Link to post
Share on other sites

Hey can anyone help me I have just ported over my world to an new computer now none of my stargates are working can anyone tell me where the configured folder would be that I need to move over ?

Share this post


Link to post
Share on other sites

I installed the program and it works great, but I am confused as to how the IDC works. I am using it on a server and want to make sure that other people using the program can't open my iris.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.