Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
XyFreak

Draconic Control - Get everything out of your draconic reactor

Recommended Posts

No you need to install the operating system first. This is propably also the reason why the installer fails to download the last two parts: You're running Plan 9k from its floppy and there's not enough space on there.

I don't know about Plan 9k but for OpenOS you boot the computer using the floppy, execute "install" and reboot the computer afterwards. Now you can download and install anything you like.

Share this post


Link to post
Share on other sites

Thank you; Now I have everything installed properly, with one last thing to ask.

(How / what) exactly do I do to (edit / create) the /etc/draconic_control.cfg
Do I create a new file with "edit /etc/draconic_control.cfg"
or instead of /etc/drac... do just draconic_control.cfg?

This is the only question I have left.

 

Share this post


Link to post
Share on other sites
1 minute ago, JTB Interstellar said:

Thank you; Now I have everything installed properly, with one last thing to ask.

How / what exactly do I edit / create the /etc/draconic_control.cfg

Do I create a new file with "edit /etc/draconic_control.cfg"

or instead of /etc/drac... do just draconic_control.cfg?

This is the only question I have left.

 

You can do either of the following:

cd /etc/

edit draconic_control.cfg

 

OR

 

edit /etc/draconic_control.cfg

Share this post


Link to post
Share on other sites

Your first guess is correct. You use "edit /etc/draconic_control.cfg" to create the file and then set up your reactor. The easiest way to do this is by copy&pasting a preset from the website and then put in your adapter addresses where the placeholders are.

Share this post


Link to post
Share on other sites

Hello,

I am running Draconic Evolution 1.10.2-2.0.10.199 on a Feed The Beast Beyond (1.6.1) multiplayer server (the server has 8gb RAM dedicated to the .   I have a draconic reactor set up, pretty much stock, with basic I/O crystals on either end (draconic energy relay crystals in the middle) back to a T8 energy core with close to 300B RF stored in it. I'm using OpenComputers 1.6.2.7 and have a T3 computer, 2x2 T3 screens, max T3 RAM, T3 proc, etc and the 3 adapters set up on the drainback, output and reactor (the stabilizer with the output flux gate)...and I'm running the latest version of Draconic Control (1.42).  dc_gui works fine and shows status of everything properly, so I know all the addresses are correct. 

I warm up the reactor and power is dumped into it very quickly and the containment field jumps up to 50% right off the bat and the core temp gets up to 2000 fast.  I've been running several tests and right now my saturation is up to around 60% or so...it slowly loses power while it's off.  Here's where my problem begins.

If I activate the reactor, the shield makes a really big jump up to around 55% and the output starts dumping power out at like 300k rf/t.  I understand it's trying to reach the target saturation of 50% so it makes sense, however, if I look at the Reactor GUI, it tells me that the target shield rate is, let's say 30k rf/t and I look down at the drainback flux gate, it's only inputting around 27k and jumping back to the reactor GUI, my containment field keeps dropping and the energy saturation keeps dumping out at around 300k/t.  Meanwhile, the core temp climbs VERY slowly.  I've not let the energy saturation levels reach 50% because by the time I've dumped that much power, the containment field has dropped into the low 30%.  I keep checking the drainback flux gate and it's consistently lower than what the draconic reactor GUI is saying it needs to maintain, so my containment field keeps going down.  

So I stomp on the shutdown button, which causes the energy saturation to climb and the computer keeps lowering the input to the core, but always lower than what the reactor GUI says it needs. 

I am using the stock configuration (copied it from the website and put it in /etc/draconic_control.cfg) have all parts of my setup chunkloaded (reactor and T8 energy core, all cables, computer, etc..) however, I've never left the chunk it's running in cause this thing scares the crap out of me :)

Shouldn't the computer keep the containment field at least 50% constantly, except in shutdown?  I've not just 'let it go' to see what happens, not looking for anymore holes in my game. 

What would REALLY be awesome would be if someone would put up a Youtube video of the startup sequence so reactor newbies could see what happens/expected behaviors.  

Thank you for reading this far down and I look forward to any comments/suggestions that anyone might have. 

Thanks!

Share this post


Link to post
Share on other sites
16 hours ago, ZureaL said:

Hello,

I am running Draconic Evolution 1.10.2-2.0.10.199 on a Feed The Beast Beyond (1.6.1) multiplayer server (the server has 8gb RAM dedicated to the .   I have a draconic reactor set up, pretty much stock, with basic I/O crystals on either end (draconic energy relay crystals in the middle) back to a T8 energy core with close to 300B RF stored in it. I'm using OpenComputers 1.6.2.7 and have a T3 computer, 2x2 T3 screens, max T3 RAM, T3 proc, etc and the 3 adapters set up on the drainback, output and reactor (the stabilizer with the output flux gate)...and I'm running the latest version of Draconic Control (1.42).  dc_gui works fine and shows status of everything properly, so I know all the addresses are correct. 

I warm up the reactor and power is dumped into it very quickly and the containment field jumps up to 50% right off the bat and the core temp gets up to 2000 fast.  I've been running several tests and right now my saturation is up to around 60% or so...it slowly loses power while it's off.  Here's where my problem begins.

If I activate the reactor, the shield makes a really big jump up to around 55% and the output starts dumping power out at like 300k rf/t.  I understand it's trying to reach the target saturation of 50% so it makes sense, however, if I look at the Reactor GUI, it tells me that the target shield rate is, let's say 30k rf/t and I look down at the drainback flux gate, it's only inputting around 27k and jumping back to the reactor GUI, my containment field keeps dropping and the energy saturation keeps dumping out at around 300k/t.  Meanwhile, the core temp climbs VERY slowly.  I've not let the energy saturation levels reach 50% because by the time I've dumped that much power, the containment field has dropped into the low 30%.  I keep checking the drainback flux gate and it's consistently lower than what the draconic reactor GUI is saying it needs to maintain, so my containment field keeps going down.  

So I stomp on the shutdown button, which causes the energy saturation to climb and the computer keeps lowering the input to the core, but always lower than what the reactor GUI says it needs. 

I am using the stock configuration (copied it from the website and put it in /etc/draconic_control.cfg) have all parts of my setup chunkloaded (reactor and T8 energy core, all cables, computer, etc..) however, I've never left the chunk it's running in cause this thing scares the crap out of me :)

Shouldn't the computer keep the containment field at least 50% constantly, except in shutdown?  I've not just 'let it go' to see what happens, not looking for anymore holes in my game. 

What would REALLY be awesome would be if someone would put up a Youtube video of the startup sequence so reactor newbies could see what happens/expected behaviors.  

Thank you for reading this far down and I look forward to any comments/suggestions that anyone might have. 

Thanks!

The controller is working as intended for you. On default settings the containment field stabilizes around 20%. I WILL make a youtube video because many ppl have trouble setting it up correctly it seems. Anyways - your setup seems to work fine.

Do NOT worry about the temperature as long as it is not above 9000. The default settings are going to throttle the reactors output between 8000 -> 9000 C (= it's adjusting the target saturation from 50% to 90%) between 9000 and 9900 the output rate will be reduced from 100% to 0%. Anything above 9900 will trigger an immediate shutdown (although it should do so before that point is reached).

Do NOT worry about the containment field unless it either starts dropping rapidly when it's well below 20% on default settings or it gets lower than 8% (which should NEVER EVER happen on default). Anything above 0 is perfectly fine.

Why is the controller keeping the containment field low?

To keep the containment field at higher levels, you're required to pump in more RF per tick. But since anything above 0% is fine, we can save a lot of energy by having the containment field low. How much energy you ask? Keeping the containment field at 50% cost 50% more energy than keeping it at 25%. 25% costs 16% more energy than 12.5%. You might've guessed it: The formular is: <somevalue> / (1 - field_percent).

If you go to the preset page and use my special settings, the containment will go to roughly 9.09%, dropping somewhere to 8.xx% if you cut the load and suddenly put load on it again. I'm running these settings on a server on...like...11 (?) reactors now.

Do not worry!

If your reactor is setup correctly, it is extremely hard to make it explode by accident. I blew up 4 reactors on my server:

  • 3 blew up simultaineously because of dimension loading issues (do not put your reactor in a different dimension than your energy storage. Do NOT do it!)
  • 1 blew up because I accidentally put a flux point directly on a stabilizer - with unlimited throughput. INSTA FIREWORKS!

I've really tried everything (= could occur during normal operation) to blow them up - including cutting the load and reapplying it when the reactors were nearing their shutdown sequence (which is the most dangerous stage). Everything is still running.

 

Last but not least some explaination:

The jump in the containment field you see is because the controller did not yet run again and reset the feedback gate yet. It's still running at 1M rf/t for a few ticks, thus the surge in containment field strength you saw.

Actually "running" the reactor at 2000 is propably impossible. I acidentally cut the load to one of the reactors entirely so it went to 100%ish saturation with 0rf/t output - and temps did not go below 2150 C (at ~11% fuel conversion).

 

EDIT: Fixed my math (facepalm)

Share this post


Link to post
Share on other sites

I'm having a bit of an issue with this script.  I'm using the latest version as of this post and the version of Draconic Evolution that is in the Direwolf20 1.10 v1.10 mod pack (2.0.10.199 I believe it is).  I believe that I have everything set up correctly but I'm quite new to Draconic Evolution as well as the Draconic Reactor so I may have screwed something up.

 

Anyway, I was able to create the computer just fine and am able to get the Draconic Control installed and the service to start without any error messages (verified by being able to stop it).  However when I try to launch the gui (dc_gui) I get the following error:

 

Draconic Control has not been configured yet.

Please make sure everything is set up correctly and start this program again.

 

Then when I check to see if draconic control is running, it is not.  I'm using the default draconic_control.cfg file that I copied and pasted from here: (https://tenyx.de/draconic_control/advanced.html#presets) and I've verified that the addresses are correct.

 

I'm not sure what the problem may be.

Share this post


Link to post
Share on other sites

@Meathammer

The message tells you exactly what your problem is ;)

The controller was either unable to load your configuration or couldn't find it alltogether.

Note that the controller only loads the configuration ONCE so if you started it without any configuration present, you'll have to restart the computer in order to "activate" the "new" configuration.

Other than that please make sure you've put your config file under /etc/draconic_control.cfg.

And just to make sure that I didn't screw up any of the examples, here's a known to be working configuration from my test world:

reactors = {
	{
		reactorAddress = "3dc38bf6-2001-45da-aab8-862dd034c53d",
		fluxGateDrainbackAddress = "b805d044-3a16-4382-86f7-4f59f56a4c68",
		fluxGateOutputAddress = "ba9149fa-c468-4633-85cc-6dc28fc410a4",
		drainback = 1.1,
		targetSaturation = 0.1,
		throttleSaturation = 0.56,
		throttleTemperature = 8115,
		throttleExponent = 0.12,
		limitTemperature = 10000,
		limitExponent = 2.79,
		burnRFt = 2000000
	}
};

If you keep having problems, let me know.

Share this post


Link to post
Share on other sites
Guest

I'm having trouble with the computer. The controller works fine except for the fact that it doesn't  drain power out of the reactor.

I'm using this config

reactors = {
	{
		reactorAddress = "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX",
		fluxGateDrainbackAddress = "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY",
		fluxGateOutputAddress = "ZZZZZZZZ-ZZZZ-ZZZZ-ZZZZ-ZZZZZZZZZZZZ",
		drainback = 1.1,
		targetSaturation = 0.10,
		throttleSaturation = 0.56,
		throttleTemperature = 8115,
		throttleExponent = 0.12,
		limitTemperature = 10000,
		limitExponent = 2.79,
		burnConversion = 0,
		burnRFt = 2000000
	}
}

I'm using the energy crystals from Draconic to transfer the energy to a tesseract from Thermal Expansion.

Share this post


Link to post
Share on other sites
On 5/29/2017 at 3:24 AM, XyFreak said:

@Meathammer

The message tells you exactly what your problem is ;)

The controller was either unable to load your configuration or couldn't find it alltogether.

Note that the controller only loads the configuration ONCE so if you started it without any configuration present, you'll have to restart the computer in order to "activate" the "new" configuration.

Other than that please make sure you've put your config file under /etc/draconic_control.cfg.

And just to make sure that I didn't screw up any of the examples, here's a known to be working configuration from my test world:


reactors = {
	{
		reactorAddress = "3dc38bf6-2001-45da-aab8-862dd034c53d",
		fluxGateDrainbackAddress = "b805d044-3a16-4382-86f7-4f59f56a4c68",
		fluxGateOutputAddress = "ba9149fa-c468-4633-85cc-6dc28fc410a4",
		drainback = 1.1,
		targetSaturation = 0.1,
		throttleSaturation = 0.56,
		throttleTemperature = 8115,
		throttleExponent = 0.12,
		limitTemperature = 10000,
		limitExponent = 2.79,
		burnRFt = 2000000
	}
};

If you keep having problems, let me know.

Thanks for the help.  I figured out that my config file had some syntactic errors.

Share this post


Link to post
Share on other sites
13 hours ago, tnt84268 said:

I'm having trouble with the computer. The controller works fine except for the fact that it doesn't  drain power out of the reactor.

I'm using this config


reactors = {
	{
		reactorAddress = "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX",
		fluxGateDrainbackAddress = "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY",
		fluxGateOutputAddress = "ZZZZZZZZ-ZZZZ-ZZZZ-ZZZZ-ZZZZZZZZZZZZ",
		drainback = 1.1,
		targetSaturation = 0.10,
		throttleSaturation = 0.56,
		throttleTemperature = 8115,
		throttleExponent = 0.12,
		limitTemperature = 10000,
		limitExponent = 2.79,
		burnConversion = 0,
		burnRFt = 2000000
	}
}

I'm using the energy crystals from Draconic to transfer the energy to a tesseract from Thermal Expansion.

Sounds like you're still on 1.7.10? If it doesn't drain power, can you please make sure that your reactor is actually in "running" mode? I think the 1.7.10 version might have a bug where it prematurely shuts down the reactor sometimes.

Share this post


Link to post
Share on other sites
Guest
On 5/30/2017 at 9:29 AM, XyFreak said:

Sounds like you're still on 1.7.10? If it doesn't drain power, can you please make sure that your reactor is actually in "running" mode? I think the 1.7.10 version might have a bug where it prematurely shuts down the reactor sometimes.

I am still using 1.7.10

I checked both the reactor and computer and they both say the reactor is on and running.

I might of screwed up the Draconic energy crystals but I'm pretty sure it got it right.

Share this post


Link to post
Share on other sites
17 hours ago, tnt84268 said:

I am still using 1.7.10

I checked both the reactor and computer and they both say the reactor is on and running.

I might of screwed up the Draconic energy crystals but I'm pretty sure it got it right.

Can you run a quick "draconic_control runOnce" and see if it errors? If nothing happens, the controller is running as intended. If it does error, can you please send me a screenshot?

Share this post


Link to post
Share on other sites
Guest
5 hours ago, XyFreak said:

Can you run a quick "draconic_control runOnce" and see if it errors? If nothing happens, the controller is running as intended. If it does error, can you please send me a screenshot?

I did the command and nothing happened, so I guess the controller works, but I still can't drain power.

Share this post


Link to post
Share on other sites

What version of DE do you have? I need to recreate this issue...somehow...

That reminds me...are you 100% sure you have the output flux gate placed the right way? It's kinda not so obvious in 1.7.10.

Share this post


Link to post
Share on other sites
Guest
2 minutes ago, XyFreak said:

What version of DE do you have? I need to recreate this issue...somehow...

That reminds me...are you 100% sure you have the output flux gate placed the right way? It's kinda not so obvious in 1.7.10.

I have the 1.0.2h version.

The way I understand the flux gate is that the orange side is the output and the purple side is the input.

I pretty sure I have the flux gates right. I did notice that when I looked at the gui for the flux gate, it said the flow was 0.

Share this post


Link to post
Share on other sites
Guest

The generation rate is about a thousand more than the field input rate. The containment field is slowly dropping though because the energy saturation is full.

Share this post


Link to post
Share on other sites

Ok I just ran the 1.3 version and it worked for me. Since your flux gate is displaying 0 RF/t this has to be something computer related.

There are two things I can think off:

  • Your adapters got confused (yes that CAN happen)
  • The controller entered failsafe mode. In this case it should attempt to shut down the reactor as soon as your energy saturation reaches 99%. If you haven't waited for that long (I'll just assume you have already) then please do. If it does get shut down failsafe was active.

Eitherway try this: Shut down the reactor and break and replace the output flux gate AND the adapter. Also replace the crystals. After this you'll have to reconfigure the output adapter address. Things should work afterwards.

Share this post


Link to post
Share on other sites
Guest

Oh that makes a lot of sense. I'll respond with the results

Share this post


Link to post
Share on other sites
On 6/1/2017 at 5:04 PM, XyFreak said:

Ok I just ran the 1.3 version and it worked for me. Since your flux gate is displaying 0 RF/t this has to be something computer related.

There are two things I can think off:

  • Your adapters got confused (yes that CAN happen)
  • The controller entered failsafe mode. In this case it should attempt to shut down the reactor as soon as your energy saturation reaches 99%. If you haven't waited for that long (I'll just assume you have already) then please do. If it does get shut down failsafe was active.

Eitherway try this: Shut down the reactor and break and replace the output flux gate AND the adapter. Also replace the crystals. After this you'll have to reconfigure the output adapter address. Things should work afterwards.

I am having the same issue as tnt84268. I have tried replacing the crystals, flux gate, and adapter. The reactor says it is running and healthy, but the output RF is always set to 0. The feedback controller is working as intended.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.