Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

Draconic Control - Get everything out of your draconic reactor

Recommended Posts


You're totally correct. I haven't heard about the browser cache thingy before. Just why would they do that?

BTW I have made a 20 TRF reactor scheme (some modifications in the config file):

.\draconic_simulator_64.exe drainback=1.02 target_sat=0.2 throttle_sat=0.975 throttle_temp=8000 throttle_exp=0.005 panic_temp_base=12000 panic_exp_base=0.01 burn_conversion=0 burn_rft=0 fuel=max energy_generation_mult=1.25 fuel_usage_mult=1.5 output_distance=600



Reactor shut down after 14384597 ticks ( 8 days 7:47:09.850 ).
Reactor shutdown took 3164897 ticks ( 1 days 19:57:24.850 ).
RF Generated: 2.01637e+13 ( over generation time: 1.79717e+06 RF/t | over total runtime: 1.40176e+06 RF/t )
RF required for shutdown: 3.90832e+10 ( 0.194% of total generation )
RF/t peak: 4.390e+06 RF/t
RF/t drain peak: 1.568e+06 RF/t

Link to post
Share on other sites



How long does using the default preset take to reach ~1.1M RF/t? I've had the reactor running for about 2 days now, so roughly 48 hours and this is the current output.

As you can see its no where near 1.1M Rf/t. The output is rising very very slowly, but the containment field input never seems to change, also the temperature is currently 4185, and hardly seems to be rising to anywhere lose to 8000. should it be this slow or should it have reached 800 by now and be outputting much higher power? If so then whats slowing mine down?


I'm running FTB Revelation 1.6.0, which is MC 1.12.2 and Draconic Evolution 2.3.9.


Link to post
Share on other sites

Hey @m_2018

The default presets take quite a while to get going. What's "slowing you down" is the energy saturation target. As you can see, it's kept at a constant 50%. As fuel conversion increases, energy generation increases as well so that's where the gain in energy generation comes from. You can set the saturation target to something lower (without touching the throttling) to speed everything up if you want. The default presets are only meant for making sure everything is fine tbh ... i thought more ppl would jump on the maxrf/t train :P

EDIT: If you don't want to mess with any setting and just throw in a number, use 25% for the target saturation. That'll get things going a lot faster.

Link to post
Share on other sites

Hello community,

Having some problems getting the computer setup. 

Direwolf20 1.8 creative test world

Minecraft 1.12

OpenOS 1.7.1

DE 2.3.8

Reactor and storage are built to spec afaik

Adapters are addressed correctly afaik

Draconic Control starts and doesnt throw an error but when I try to run dc_gui it says Draconic Control has not been configured yet..



What am I missing?

Link to post
Share on other sites


Could it be possible for Version 1.3+ to remove the redraw for the gui? On the current FTB 1.7.10 server the part with all those values (energy I/O rate, fuel conversion, ...) is blinking which means/seems to be redrawn.
Would be nice to have a static ones where only the values are getting redrawn.

Also the GUI can not be inserted to start with the computer, can this added please to?

Then I don't know how to monitor multiple reactors, can you post an example config for it please?

And last thing is that on https://tenyx.de/draconic_control/1.7.10/advanced.html#presets are all values comma-separated but on https://tenyx.de/draconic_control/1.7.10/#download values are semicolon-separared.
I tried to comma-separate them like seen on the first link but then the GUI fails so either all values must be semicolon-separated or smth. goes wrong.

Would be nice if you could lookup all those points and hopefully a computer reboot/server reboot with computer reboot does not blow up the reactor since a few secounds are needed for a full os restart ^^

Link to post
Share on other sites

Hey @Chaoschaot234

My libGUI should only redraw stuff that actually HAS to be redrawn - except when a redraw is forced which should only happen on resolution changes. I'll look into it. Are you sure the static stuff is blinking?

You can set up the gui start yourself by ... umm... i think editing /home/.profile or something - there're posts here on the forum that explain how i think.

At the present you can not monitor multiple reactors. The GUI doesn't support it - it's a flaw i know about and i actually have a modified version that is extremely wonky that CAN do it xD. Maybe I'll cook up something for that...

For the config file it doesn't actually matter whether you coma-separate stuff or use semicolons. How does the GUI fail? You need to restart the reactor service after you changed the configuration file. Safest way is to reboot the computer.

If you're not doing crazy breeder shenanigans the reactor will survive a computer reboot without any issues. Infact.... your reactor is gonna be safe if the computer crashes between 30%ish and 80%ish fuel conversion and doesn't come back on until it leaves that range - you're going to lose RF/t tho.

Link to post
Share on other sites
9 minutes ago, Chaoschaot234 said:

@XyFreak - After Server restart the Reactor was gone so it seems that smth. goes horrible wrong either with the OC Computer or with the script itself. Main control service was definitly included to run at restart.

This happened to me as well, I believe what happens is that the script stops running or something and it then processed to blow up when the server is restarting

Link to post
Share on other sites
Just now, Saber404 said:

This happened to me as well, I believe what happens is that the script stops running or something and it then processed to blow up when the server is restarting

This is true, since on a server reboot all threads are stopped/freezed and after reboot is compleated it should continue with normal operation. And if you have enabled the autstart over "rc draconic_control enable" it is definitly started on every
computer reboot.

I am not sure if smth. can be done about this because it looks like a problem on OCs side self, which I try to figure out now.

Link to post
Share on other sites

I had the same issue when using EnderIO OC conduits. Those conduits are bugged as hell and are counted for one component each the first tick after server reboot, which causes your computer to crash. I "fixed" the issue by reducing the number of conduits used and using a server with a lot of component cards.

TL;DR Don't use EnderIO conduits and build the computer in the same chunk as the reactor ;)

Link to post
Share on other sites
6 minutes ago, XyFreak said:

I had the same issue when using EnderIO OC conduits. Those conduits are bugged as hell and are counted for one component each the first tick after server reboot, which causes your computer to crash. I "fixed" the issue by reducing the number of conduits used and using a server with a lot of component cards.

TL;DR Don't use EnderIO conduits and build the computer in the same chunk as the reactor ;)

No, the problem seems to be, that after the server restarts, that the Addresses from all devices are changed. I am glad to have backups because the GUI was totally froozen. After reboot and restarting the GUI, while I have deactivated the reactor and connected the cryo flux ducts directly to the field injector, I checked over 

what the addresses are and the address from the reactor chaged and this after a server reboot? I am a bit confused about this and maybe I should ask a bit arround on the OC discord and I should checkout if this change happends only beause I've lookd in SP for the backup to work or if this comes directly from the server restart. Will responds after getting more information about this.

Link to post
Share on other sites

In SP it changed definitly, now I am going to see if it changed in MP to and if so, I hope to get a bugfix for 1.7.10 from the OC team, since with your default settings the reactor runs at 20% field level and I have not many time to fastly feed energy in the FF to make it stable, to then disconnect the output cable ... otherwise booom!

ok - it is impossible to fix it directly on the server which means that the address of the device was changed like I have noticed in SP which is not good - when I fixed this and saved the reactor, I'll do a restart again from the server to see what will happen than and
if I see new/other addresses again, smth. went wrong, maybe because of false chunkloading?

Ok, here are images from the first setup and after the restart ... one address changed ... one from those flux gates, why ever ... pls look close at the files name to see the difference in the time.



Link to post
Share on other sites

There is a sanity check in there but if the computer looses control of the flux gates / reactor there is nothing that can be done.

For e.g. if the connection to the reactor is lost, it tries to set the output fluxgate to 0 and keeps the input at the last known to be good value.

As long as the reactor is still connected and the input flux gate (control over output is lost) It'll keep the containment stable.

There's also code that shuts down the reactor but that only happens once the reactor is over 99% saturation. The reason for that is that we don't know if shutting down the reactor will cause a brownout and subsequently cause the containment to fail.

The issue here is that we lose control over both flux gates and can't do anything. The reactor is never gonna go to 99% saturation and we're screwed. You CAN just replace the check at line 252 with a true to have the failsafe always shut down the reactor if something happens tho.

Link to post
Share on other sites

Ok, I must compleatly do a hard reset and I'll definitly change the line 252, if this comes live again. TO bad that getting back te flux gate control isn't possible :(

EDIT: Indeed smth has broken the controll over the flux gates :(

Edit 2: Can you tell me, where the mainscript is stored @XyFreak ?

Edit 3: Ok, from the Discord chat it seems that the flux gate does not save the OC data correctly. This is like hell -.-

Link to post
Share on other sites
12 hours ago, HiggyHLyoung said:

roughly how long will it take the reactor to reach max RF/T ?

That's a difficult question but I hope this graph will explain it a bit for you:


The blue line is the default config and the red "line" is the max rf/t config.

As you can see the power output of the default config will continue to increase until the thermal limit is exceeded and then shut down shortly after.

The max rf/t ones power output will increase at first until 2000000 rf/t is reached and then starts oscillating. The resolution of the graph isn't high enough so you see that red block there. The average energy output is somewhere in the lower third of that thingy (propably 1/3 * max + 2/3 * min). After reaching a certain temperature it'll quickly shut down here as well.


Here's the same graph with dots only:


Link to post
Share on other sites

Hey there,

i run into a Problem and i dont know if its a Bug in DE or OC or in your Program but, i setup everything as it should
and i can warmup the reactor just fine. Then i can Activate it too. Then it starts running crazy. The Energy Saturation
just runs in a few seconds to 100% and the Reactor shutsdown. I've added some Screenshots to imgur wich shows
the stuff happening and the Setup. 

Im using DW20 1.12.2-2.3.0 Mod Pack from Twitch
DE Version: Draconic-Evolution-1.12.2-
OC Version:  OpenComputers-MC1.12.2-

Here are some Screenshots wich shows how fast it grows till the Reactor shutdown. If you need more Informations
or something else, let me know.: https://imgur.com/a/q1IQXQw
Thanks in advance

Link to post
Share on other sites


The reason the reactor is shutting down is because you enabled "failsafe" - this option doesn't do what you think it does and i advise against using it - it becomes useless after past 11% fuel conversion anyways.

The reason your reactor is filling up is because energy can not be transferred away from the core fast enough (if at all)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.