Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
XyFreak

Big Reactors Grid Control

Recommended Posts

4 hours ago, MrSmirkNMerc said:

OK I wanted to make sure. I drained my cell to under 50% and thought that it should've kicked in by then. I put the Holding IV enchant on the cell and it holds 150 mil. I was thinking about going into Draconic next. I also have Capacitor Bank of 50 mil, but I was reading that you need a mod that I don't have installed for the adapter to interact with the capacitor bank. Thanks for the info.

I just ran the energy down to under 10% capacity and the turbines kicked in. However they only stayed on for a few minutes until the cell was filled to about 20% percent and then shut off. Is there a way to set the threshold of when the program shuts the turbines off again to a higher percentage?

Share this post


Link to post
Share on other sites
On 9/26/2018 at 5:14 AM, MrSmirkNMerc said:

I just ran the energy down to under 10% capacity and the turbines kicked in. However they only stayed on for a few minutes until the cell was filled to about 20% percent and then shut off. Is there a way to set the threshold of when the program shuts the turbines off again to a higher percentage?

Do you have something else feeding into the energy storage? If so that might be enough to fill increase your storages charge. If not then this should not happen. Does the GRID display show the cell being 20% full as well? Do you have multiple turbines?

@Daggz I'll look into it, thanks. brgcctrl has never really been my main focus so I tend to overlook stuff in there. If you really NEED it you could set the OC CPU to Lua5.2 but that error right there is 100% my fault.

Share this post


Link to post
Share on other sites
14 hours ago, XyFreak said:

 

@Daggz I'll look into it, thanks. brgcctrl has never really been my main focus so I tend to overlook stuff in there. If you really NEED it you could set the OC CPU to Lua5.2 but that error right there is 100% my fault.

That's fine, I'm just amazed and thankful someone took the time to even develop something like this. 
Thanks once again, I've got it working great in 2 stations currently but having a hard time on my 3rd with calibration of the reactor. 
It only supplies 700mb for 2 turbines (5x5x27 + 37 enderium blocks same as other working configs) and I'm not sure what I'm doing wrong. 
Been reinstalling the mod with different presets on the reactor and machine but it still yields 700mb despite a clean drive and OS. 

Figure if I can ask the reactor to recalibrate that could help :)

Have a nice day, thanks again!

Share this post


Link to post
Share on other sites

It's a bug in the command line tool specifically.. though I was pretty sure i fixed this ages ago... You CAN "fix" this by going into Lua 5.2 mode but that's something i need to fix tbh.

Thanks

Share this post


Link to post
Share on other sites

I'm having some trouble with BRGC...
I have an actively cooled reactor running two turbines, which are charging a Draconic Evolution Energy Core.

Without BRGC, the reactor produces 4000mB/t steam, which is piped out to the turbines. After connecting only the reactor to BRGC, it calibrated and set the rod insertion to 96% or higher.
This cuts steam output down to about 1600mB/t and my turbines are barely spinning. Why does BRGC set the rod insertion so high?

I assume I'm doing something wrong here, but I'm not sure what. Can someone point me in the right direction?

Thanks!

Share this post


Link to post
Share on other sites
38 minutes ago, squidflex said:

I'm having some trouble with BRGC...
I have an actively cooled reactor running two turbines, which are charging a Draconic Evolution Energy Core.

Without BRGC, the reactor produces 4000mB/t steam, which is piped out to the turbines. After connecting only the reactor to BRGC, it calibrated and set the rod insertion to 96% or higher.
This cuts steam output down to about 1600mB/t and my turbines are barely spinning. Why does BRGC set the rod insertion so high?

I assume I'm doing something wrong here, but I'm not sure what. Can someone point me in the right direction?

Thanks!

I'm not an expert but as far as I know you need to hook the turbines in because BRGC will adjust your reactor to output exactly what the turbines need, without the turbines hooked up it could be confused. 

The other possibility is that you need to use the GUI, to go to the battery page and click charge, by default it will try to produce the same amount of power that you are currently using therefore keeping the battery at a steady level instead of charging to max. 

I'm not sure of exactly what the button names are so those are approximate instructions. 

Hope one of those things helps! 

Share this post


Link to post
Share on other sites
41 minutes ago, Luke Brehm said:

I'm not an expert but as far as I know you need to hook the turbines in because BRGC will adjust your reactor to output exactly what the turbines need, without the turbines hooked up it could be confused. 

The other possibility is that you need to use the GUI, to go to the battery page and click charge, by default it will try to produce the same amount of power that you are currently using therefore keeping the battery at a steady level instead of charging to max. 

I'm not sure of exactly what the button names are so those are approximate instructions. 

Hope one of those things helps! 

Ah, my bad...I omitted that I've tried setting up BRGC a few times now. Even with the turbines and the Energy Core attached, BRGC sets the rod insertion upwards of 96%.

This improves fuel depletion considerably, but it greatly reduces the amount of steam produced.

As expected, if I disconnect the OC cable from the reactor and reduce the rod insertion, the steam output is fine again.

With the turbines attached to BRGC, the controller shuts down one of the turbines after increasing rod insertion to 96% or higher.

Should I only run one turbine off my reactor?

Thanks!

Share this post


Link to post
Share on other sites

@squidflex 
So everything is hooked up. Can you please hit the "CHARGE" button on the GUI and see if that changes anything for you? If it does then BRGC simply decides, that it's overproducing energy. Although 1600 mB/t sounds odd (as it should be 2000 mB/t -> 1 turbine).

Share this post


Link to post
Share on other sites

@katt1204 You are running OpenOS 1.5 - that sounds REALLY old to me. I think i tested the earliest version of brgc against OpenOS 1.6 so... your only option is to upgrade i think.

Honestly you might get away with not using brgcctrl and start the services directly on your own but that's just speculation. Upgrading OC is your best bet.

Share this post


Link to post
Share on other sites
On 12/7/2018 at 4:13 PM, XyFreak said:

@squidflex 
So everything is hooked up. Can you please hit the "CHARGE" button on the GUI and see if that changes anything for you? If it does then BRGC simply decides, that it's overproducing energy. Although 1600 mB/t sounds odd (as it should be 2000 mB/t -> 1 turbine).

I enabled charging and I tried recalibrating the reactor as well.
It still increases the fuel rods until the reactor is only producing 1.86mB/t of steam.

Hmm...I just manually changed the fuel rod insertion back to 0% and it seems to be running fine now.
BRGC hasn't tried to adjust the fuel rods since then, the 4.00B/t is reporting properly on the displays, and the turbines are approaching optimal speed.
Maybe it's something with my setup?

Thanks!

Share this post


Link to post
Share on other sites

If BRGC does not set the fuel rods then something is broken. It does that every .5 seconds so....

I'll try to reproduce the issue but by the looks of it something is going wrong somewhere... is there any way for me to debug it on-site ;)

Share this post


Link to post
Share on other sites
14 hours ago, XyFreak said:

If BRGC does not set the fuel rods then something is broken. It does that every .5 seconds so....

I'll try to reproduce the issue but by the looks of it something is going wrong somewhere... is there any way for me to debug it on-site ;)

I mean, i guess it could be setting the fuel rods, but it hasn't dialed the insertion way up like it was before.

Sure! I'll send you a PM with connection info, etc. Thanks!

Share this post


Link to post
Share on other sites

And i got a new issue. My reactor is giving 2k mb/t and i need 5.6k mb/t its giving that amount if the turbines are in kickoff mode then they get suspended and stop working any fix?

 

Share this post


Link to post
Share on other sites

What I'm more concerned about is that the error @Crack3dC0d3 posted can't/shouldn't happen. The code explicitly tests for nil there and there's a line offset by one.

So either he uses an older version or the sources on my server are not what they should be....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.