• Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Welcome to OpenComputers

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

  • Announcements

    • Lizzy Trickster

      Latest Stable OpenComputers Version   11/26/16

      The latest released version of OpenComputers is version 1.6.1 for MC 1.7.10, 1.8.9, 1.9.4 & 1.10.2. See more information here! Beta/Dev builds can be found at the Jenkins Build Server (ci.cil.li)

DarkPikachu

Members
  • Content count

    44
  • Joined

  • Last visited

  • Days Won

    6

About DarkPikachu

  • Rank
    Junior Member
  • Birthday 02/08/91

Contact Methods

  • Minecraft
    Tcll
  • GitHub
    Tcll

Profile Information

  • Gender
    Male
  • Location
    The Darkness
  • Interests
    Programming, inventing, ... pretty much anything logically creative.

Recent Profile Visitors

243 profile views
  1. I did get that, but I don't remember how I fixed it... Are you installing everything correctly??
  2. I would like to look into that error and fix it myself, but I got other stuff in the way atm: UGE, SIDE, UGESL, OCHL, my forum (plugins), and a bunch of sub-projects for all those major projects... I'm also working on some stuff (such as an OS) for OCLights, where it's screens have blitted framebuffers that can display in 24bit color, and can even display images through it's API.
  3. hold the CPU in your hand and R-click (I forget if you need to Shift)
  4. is that with my image?? I think I get that error when I use lua 5.3... try switching the cpu to the older API and it should work.
  5. btw, figured out a way to do Hard Light morphs, and yes it will be an extension mod. the cool part is the idea won't affect Steve himself, so you can use mods like CustomSteve without issues. so the idea revolves around the movie Surrogates. if you haven't seen the movie, you basically lay in a bed and put on these goggles which control a robot with your mind... this robot can impersonate as a younger version of you or even another person. I think you know where this is going... so in my version, you stand in a tube and "transfer" your "consciousness" to your model. now some realism does take effect, you can't "eat" as your model, meaning you have to leave whenever you get hungry, or go in with Saturation, and whenever you take damage, or get hit with effects as your model, the damage/effect is inflicted on Steve, so wear your best repellent/healing armor before going in. (magical effects though should be able to be used through the model, such as restoring hunger with the healing axe) also note, each model has it's own inventory, so don't expect to go in with items and be able to use them across models. EDIT: btw nifty feature, since your model is projected and can only travel as far as the projector can cast, you can recast your model to a new location within the projector's range. this is all controllable via your inventory key, which brings up the virtual inventory rather than your inventory.
  6. yes, but barely, I have other major projects and a forum to manage, so really I only tackle this when I ever focus on it, being rarely... (this is what happens when you have an overactive mind that has too many ideas and little knowledge) ^ oh and being without internet for years doesn't help either... I'm currently still trying to learn how to create an entity, if anyone could provide an example source, I could get things working faster this phone certainly can't help me with it's limited data, and this glitchy editor makes it really hard to explain things... (line breaks are impossible and can't be deleted, and the cursor goes stupid and jumps all over the place when clicking on one) ^ what's wrong with a basic text editor and bbcode?
  7. I've been translating a few things here a there on my phone, but I wouldn't go as far as to start uploading anything any time soon on this stupid thing... keeping it to 1 file a time until I get some real internet. ;) (whenever that'll be 9_9) if nobody does anything before then, I'll have some treats for people ;)
  8. EDIT: (stupid max character length) the link has been updated it should work now ;)
  9. oh... that could be the config file... oops... I've removed the download on mega for now, I'll edit it with the new link when I rebuild and upload tomorrow... haha EDIT: just to note, I'm only modifying the config file, MineOS creates new entries when you first login, so it's pretty much the same image :P I'm not too worried about my insecure actions, as the OS doesn't do a good job of protecting the information anyways... lol but to add, I won't ever be stupid enough to put anything needing security on my machines to begin with... :P
  10. @LastAIif by locked you mean frozen (at the boot screen), it happens to me too, just restart the computer, it will eventually get through. that was the glitch I reported earlier, and yes, it happens quite often... I think it's due to your real computer not having enough power to run Minecraft well, wait until your FPS picks up for the best results. (my computer runs Minecraft at around 16 to 24 FPS, for comparison)
  11. btw @EliteClubSessions why did you not modify the search paths of the package module so you could use require() on local modules?? I'm working on fixing up the minecode app with more than what you have in your beta source and have had to work around loading local modules using loadfile() which was a B to figure out. (the rest variable isn't always in _G which caused a few issues in building the loader) I did build a working loader, but the fact I had to should not be the case.
  12. you know what... screw his rule, I'm contributing to his work. It's not like I'm redistributing a modified version, or trying to make an income... no I'm trying to make people's lives easier (unlike the devs of this forum), so I don't think he'll mind. it'll likely be outdated though... anyways, here's the link: https://mega.nz/#!otB1WSpS!KC58QGPkORWyXwohzrGWoFSg4tCOFofsemWxifdyhAs this is an unmodified backup of my initial installation. I did this so I could install it on other drives without going through the grueling process again. @forum devs: please make it possible to edit raw text, the current editor has sucked since I started using this forum.
  13. do you have an offline version of your converter?? can't exactly drop images on a phone... trying to make an image for my MineOS desktop bg :P

     

     

     

  14. I think it might have something to do with OC's cruddy networking that's been plaguing my NetBiOS development since I started it... half my files don't "load" and by that I mean I was working on a hot-loader which downloaded the data to RAM and attempted to load it. might I say, it was very sparatic and didn't work as expected... file not found errors everywhere, even if they loaded before... EDIT: even though it's tedious and annoying as F... I actually have to recommend manual installation, I'll rework my tutorial with every step when I'm actually on a computer. sad because I actually had an image of what the apps folder was supposed to look like... EDIT2: I just realized, what version of lua are you guys using?? despite my issue it might be installing correctly, but there's 2 things that might just be killing this: 1: I get errors when I switch to lua 5.3 my screenshot was posted using lua 5.2 2: remember when I mentioned the drive state? what if OC is restoring OpenOS's operational runtime files while OpenOS is running? that would cause missing field errors like that. EDIT3: for 2, not sure if this will work, but if you're using a "Managed" drive, try switching it to "Unmanaged" and reinstall. if this doesn't fix the secure drive-state issue (as in files still revert back), please let me know
  15. oh... wasn't expecting the forum to cut off the 18 steps I had written with this phone... guess that's what I get for relying on the malformed standards of another forum. EDIT: ok, that is the full code for the cfg, the forum just cut off my warning... I'll use my forum next time I write instructions...