Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
IlynPayne

SGCX - SGCraft Stargate Controller

Recommended Posts

20 hours ago, Atoz said:

hello I was wondering if we can add a search option to it so it will be easyer to find the gate address

Good idea. I will implement it in the near future. maybe along with address grouping.

Share this post


Link to post
Share on other sites

I made an update.

New stuff:

  • Address grouping
  • Searching by name within a group

Running the updated version of the script will result in conversion to the new storage format. The old one used a single configuration file /etc/sg.cfg, whereas the new one uses /etc/sgcx.cfg and /etc/sgcx.d/*. The latter is used to store address groups in separate files so they can be easily exported. Storage format upgrade doesn't delete the old configuration file, so in case of any error the existing configuration isn't lost.

Share this post


Link to post
Share on other sites

Hi i wanted to try your version of the Stargate Dialing Computer and after i installed it.

The command 'sgcx init' wants me to select the stargate i want to use and i do that but shortly after that i get this error you can see in the image. I hope you find the problem.

2019-02-27_14.18.23.png

Share this post


Link to post
Share on other sites

There was a problem with setting default configuration values. Should be fixed now.

Use those commands to run an update:

arpm refresh
arpm install sgcx

 

Share this post


Link to post
Share on other sites

One (or more) of your group files is empty or is in a wrong format. Temporary workaround would be to search for empty/non-Lua config files in the /etc/sgcx.d directory and to delete them.

I couldn't reproduce this bug. I need more information:

  1. What where you doing in the script before this error appeared?
  2. Type the following commands and send their output as a screenshot:
    cat /etc/sgcx.cfg
    ls -l /etc/sgcx.d

     

Share this post


Link to post
Share on other sites

The SpaceGates.cfg file is empty and that's what prevents the script from starting. I have added a fix that informs you to delete the file manually or the script will do it for you.

I couldn't find the source of this bug though - the sentence "the default section disappeared" wasn't very helpful.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.