Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

UCQuasar

Members
  • Content Count

    4
  • Joined

  • Last visited

  1. It's fine, it was mostly just a curiosity question. I spammed a bunch of packets at the server and it seemed to crunch through them without dropping any and works great for this use case. I might take a crack at a queue system at a later time. I found that I have a 9 tick delay to send and get a response back and it takes 1 tick to send a modem message, so I'm guessing that as long as I don't send much more than 9 client messages at once without switching to an event pull then it should be fine.
  2. Your example code works perfectly for what I'm doing. Thank you very much for your help. Edit - If I wanted to send a bunch of messages at once or had two computers sending messages to the server, how would the server handle multiple messages being sent within a few ticks. Would it hang while it completes the previous message instructions and drop a packet or would it queue up the events?
  3. Hi, I have a computer connected to some adapters for my nuclearcraft reactors and I want to run commands to these adapters via modem messages. I've got the load function to execute commands such as reactor.activate and deactivate but it won't return any values such as reactor.isProcessing (true/false) or reactor.getEnergyStored(). I've got a code example below where I've skipped the modem message and made an example string. Printing test gives me a nil value but printing test2 gives me the expected value of true/false. How do I get it to return something so that I can send the info back to the requesting computer? Thanks.
  4. Edit - Ended up giving up on trying to get this to work and decided to seperate the screen parts for each server and then use a networked computer to connect to other components. I'm trying to use a server rack to have two servers where one controls three display boards and the other controls a few nuclearcraft reactors + one display screen. I've equipped each server with a gpu dedicated to each screen and the programs explicitly bind each gpu to a specific screen. I then added two terminal servers onto the rack and bound a remote terminal to each one and then used the rack gui to link the terminal servers to their respective servers. I noticed the terminal servers had their own specific screen assigned to them so I also explicitly set the terminal to each one using term.bind(). I was having trouble with the remote terminals intercepting each other so I moved the terminal server and servers into two seperate servers and I get the same issue. I have an exit function in each program that listens for the "END" button key down event. I booted up both servers and they linked to their correct remote terminal but if I press "END" in any terminal, it will close the programs on both servers. I also have an issue when both programs are closed. Sometimes, one terminal will write to both servers or they'll both write but to the wrong server. Any ideas on how to fix this.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.