Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • 0
Theelf111

setWakeMessage not working

Question

I am currently working on a project using microcontrollers and need to be able to turn them on remotely using the setWakeMessage function though i seem to be doing something wrong.

Microcontroller1:

local modem = component.proxy(component.list("modem")())

modem.broadcast(1,"start")

Microcontroller2:

local modem = component.proxy(component.list("modem")())

modem.open(1)

modem.setWakeMessage("start")

Both of the microcontrollers have a tier 2 wireless network card and the one that is supposed to turn on (Microcontroller2) has of course been turned on previously so the port and the wake message should be set but it still doesn't turn on.

 

Edit: If one of the devices is a computer and instead of a microcontroller it works perfectly fine. It just seems to not work when a microcontroller is sending the message AND a microcontroller is receiving the message.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

This is from the OC Wiki: 

Quote

Works for robots, cases, servers, drones, and tablets.

Idk if they forgot to list microcontrollers or they left them away intentionally because they aren't supported. But since drones work I don't really see why microcontrollers shouldn't.

Share this post


Link to post
Share on other sites
  • 0

I've just tried running exactly the same code you have, and it worked. Although the µC turned off right after that, as the its program doesn't have any kind of loop to keep the µC busy. This may be the reason you don't notice that it actually turns on.

Share this post


Link to post
Share on other sites
  • 0
On 7/15/2020 at 8:58 PM, Fingercomp said:

I've just tried running exactly the same code you have, and it worked. Although the µC turned off right after that, as the its program doesn't have any kind of loop to keep the µC busy. This may be the reason you don't notice that it actually turns on.

Were both of the devices microcontrollers?

Share this post


Link to post
Share on other sites
  • 0
On 7/17/2020 at 3:55 PM, Theelf111 said:

Were both of the devices microcontrollers?

Yes, I forgot to mention it, but the sender side was also a microcontroller. Note that I've tested this on the latest OC dev build for MC 1.12.2.

But I could reproduce the bug on OC 1.7.5 (same MC version). So, perhaps it was already fixed. I suggest that you also try running the latest dev build: https://ci.cil.li/job/OpenComputers-MC1.12/

There's an issue on the bug tracker that described a very similar problem. If updating the mod version doesn't resolve the problem, you could post a comment there asking the issue to be reopened.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.