Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • 0
Metasyntactical

Can't detach thread from autorun

Question

I'm attempting to auto run a program using .shrc that starts a separate detached thread.


If I run the program manually, the thread detaches properly. If I run it from .shrc on startup, it runs but does not detach. Thoughts?

Example:

local thread = require("thread");
local listenerService = thread.create(
  function()
    --Do Stuff--
  end
)
listenerService:detach()

 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 1

.shrc is run as a list of shell commands, not lua code

when you are running the file directly, the shell interpreter is guessing it is lua code, even though the extension is not .lua

to accomplish what you want, store your lua code in a separate file, for example a file named test.lua, and in your .shrc write the line: ./test.lua (or just test)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.