Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • 0
Bannon8088

OC causing severe lag

Question

First time trying out opencomputers, it's been in my modpack for a while now but it seemed interesting so I thought I'd give it a try. I build a computer, monitor, drive and components all as needed, start it up and... immediately the game freezes up for seconds at a time as soon as the computer starts up. Sometimes the computer fails to boot with the 'too long without yielding' error as well, because the game hangs for too long while it's loading. As soon as I turn the computer off, everything is fine again. I've tried this with a low tier computer, and with a tier 3 computer fully upgraded. I've tried it with multiblock monitors and single block monitors. Anything I can think of, the game freezes as soon as I turn the computer on. I can't really provide any errors though as it's not really causing any other than the 'Can't keep up!' error in the console.

According to my task manager the system has plenty of ram available and the CPU is only running at 40%. The game is installed on an SSD drive. I'm using a GTX 1070 FE and I just updated Java today.

I'm using Minecraft 1.12.2 with Forge 14.23.4.2759 and OpenComputers 1.7.3.146

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

sounds like a massively bad integration with some other mod. try creating a creative flat world, look at a block on the ground a space or two in front of you, and run `/oc_sc` to spawn a computer and start it up -- just to see if things work at all. you can troubleshoot from there

Share this post


Link to post
Share on other sites
  • 0

Well, I updated the modpack and it has the new version of forge on it now, and I removed every single mod in the pack except for forge, codechickenlib and OpenComputers and it is still causing massive lag. I even removed my resource pack and that didn't help either.

I guess that means that there's something on my computer that it doesn't like. I can't imagine what that could possibly be though.

Everything runs just fine until I actually turn the computer on. The computer sitting in the world while it's turned off is just fine. If the computer doesn't boot because of no EEPROM the display shows an error and there's no lag after that point because the computer isn't running. So it's not the display part of the computer.

Share this post


Link to post
Share on other sites
  • 0

Seems like system specific, try some basic stuff like updating drivers etc that might help, if not then try updating Java, or maybe some antivirus might be interfering. Yes I know it sounds not so probable but sometimes basic checks can save you a Huston SOS

Share this post


Link to post
Share on other sites
  • 0

Singleplayer. I'm using the FTB launcher and just playing it singleplayer.

 

It's hard to believe that it would be my PC doing this somehow as I get 60+FPS right until I turn the computer on. As soon as I do though I get these frame drops down to zero for a few seconds every now and then. Then when I turn the computer off, everything is fine again. Normally I'm playing with around 200 mod files running at the same time and it all runs just fine until that happens.

Then again I seem to be the only one having this problem too so, I don't know what to make of it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.