Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

All Activity

This stream auto-updates     

  1. Yesterday
  2. Have you already installed openos or is it running from the disk?
  3. All bugs (i know of) related to installations are now FIXED! You can now freely install Fuchas without any problems. However only dual-boot work FOR NOW. Due to the lack of "edit" command, you will have to go to OpenOS to code Fuchas programs using "edit" command. I'm planning a editor for Fuchas, i'll do it when i can!
  4. Hi, What would be the best way to track a robots movement so that you can have it return to remembered point along an already taken route. Thanks
  5. Last week
  6. I mostly fixed installation bugs, however wait that i tell the 2nd part installer to be done before re-installing fuchas
  7. I figured out the error, the main problem seems to be that, somehow, xpcall seems asynchronous only in OC machines and that so it will result in the computer finishing Fuchas/NT/boot.lua instdead of continuing Fuchas execution. Resulting in a computer halt. Second problem is that i forgot to add the "shell" library on first download. But the xpcall error is strange
  8. Thanks for reporting the installation bug and the error after installation. I will search what is causing this error to happen and i will fix it. However the error only seems to appear on OC computers but not on OC emulators :/, i guess i shouldn't rely that much on emulators for compatibility..
  9. I‘m not 100% sure, what causes the error, but it seems the installer doesn‘t handle the http request user data properly. You could try running the following command: wget https://raw.githubusercontent.com/zenith391/Fuchas/master/Installers/openos.lua installer installer Sadly I can‘t test this right now, but it might be worth trying. Edit: Ok, i figured out what is causing the error. The colon (:) in function call "data = con:read(math.huge)" in line 11 must be replaced with a period (.). So what definitely works is running pastebin get s2YZJ0T6 installer.lua replacing ":" with "." in line 11, and then run the installer. But I get an unrecoverable error on restarting the computer after successful installation...
  10. I have tried for a long time to figure out a way to read a NBT Tag from Lua but all it says when I hit enter is 'nil "0"'. For example: In reactorcraft, you can make toroid magnets, and for some reason unlike other blocks in reactorcraft, you cannot read the tank levels. So, you must get the NBT data. I looked in the mod files and found the tags, but when I put the string into the function to get the NBT Tag, it says 'nil "unknown error"', meaning it knows that it is a recognized tag, becuase otherwise with a random string nothing happens. Please help me get this data from LUA!! Thanks, DMANisAWESOME
  11. There is progress since last post, althought small progress. For example i added liblon (an unofficial Lua Object Notation , just made to be easier to parse). I also started the "Concert" graphical interface, but currently it's way too limited to be worth a new post (and presentation edit), alongside it i added the shin32 library wiki page (on GitHub). The rest of features are just installation fixes
  12. I tried installing oppm I did install oppm and it said {installing files. . .failed opening file writing: etc/oppm.cfgerror while installing files for package 'oppm' : no error message. reverting installation. . . done. please contact the package author about this problem.} idk what to do
  13. The IO module allows to send or receive redstone (or bundled cables from Project Red) signals via Redstone I/O block. Output signals are set using sources whereas input signals are detected by sensors. Those are the names of views in the IO module. Everything is controlled by actions so if you want to set up a piston doors, define a source (IO module) that is connected to those doors and then trigger an action setting redstone output on that source with, for example, bio reader or keypad (AUTH module, OpenSecurity mod). The list of steps necessary to set up a piston doors is described in the wiki.
  14. OK so, I've edited the file and rebooted the server. Now the computer screen update itself like it used to do and all the linked turbines (24 of 32) were calibrated correctly with the exception of 3 of them. One if spinning up and down on a target speed of 750 RPM (it reach the "stable" state around 720~ RPM, and then rise again to around 760~ RPM and then goes in fast spindown until it become stable again) and two that are still in kickoff state with a target speed of 750 RPM but with the flow rate set the 0 mB/t. All 3 turbines have more than 2000 mB of steam in their internal tank Edit: the grid is in "charge" mode right now
  15. @XyFreak I'll modify the file and let you know. Is this linked to the fact thet the computer screen don't refresh itself anymore?
  16. When I tried to update my test instance I noticed that no new version of OC has been uploaded to curseforge yet. That means that the timer bug is still a thing in your OpenOS installations So the "fix" is to downgrade OC (and reinstall OpenOS afterwards) or do the thing at the bottom of my post here That would explain why @ZeroNoRyouki runs into issues as well as all of your "calibration stuck" issues. I'm sorry but that is something I can't fix.
  17. Please post a schematic of your reactor so I can investigate the issue. Calibration never took longer than 3 minutes for me (passive reactor). Active reactors calibrate really fast tho.
  18. Earlier
  19. relating to signals are they are only used when utilizing the event.pull method on the wiki they state for example modem_message(Blach:blach, blah:blah) but those are more so the returns than anything you pass to the method and are what a event.pull method returns correct?
  20. im having the same issue. but i get no error when running run0nce
  21. Can you try a "brgcctrl service reactor runOnce" and see if an error occurs? Also a screenshot of the reactors GUI and the layout would be nice.
  22. I need some help, My reactor isnt calibrating. Its stuck on calibrating for like an hour now. OC Version: MC1.7.10.1.7.4.1265 BigReactors Version: 0.4.3A
  23. This is a Snippets extension for VSCode that allows you to quickly reference modules used in OpenComputer it is available via github and the VSCode marketplace. be advised it is still a VERY early release and is bound to have typos. please let me know if you find any errors or issues. https://marketplace.visualstudio.com/items?itemName=Power5000.opencomputersnippets https://github.com/power-5000/OpenComputerSnippets
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.