Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
XyFreak

Draconic Control - Get everything out of your draconic reactor

Recommended Posts

I am not sure if I am just stupid or what, but I cannot figure out how to create the .cfg file for the computer. I have read and re read your instructions on the website about 50 times, and ive tried typing /etc/draconic_control.cfg into the console and it does nothing. I have everything setup perfectly, and I just wanna get this going. Could someone please help me?

 

 

Edit: okay, I got the .cfg file create page open, but now it keeps erroring on me. and I don't know whats up. Here are some screenshots.

 

2017-06-14_03.11.17.png

2017-06-14_03.12.54.png

Edited by Flux_Adept
Resolved my first issue just to have another issue come up.

Share this post


Link to post
Share on other sites
7 hours ago, Flux_Adept said:

I am not sure if I am just stupid or what, but I cannot figure out how to create the .cfg file for the computer. I have read and re read your instructions on the website about 50 times, and ive tried typing /etc/draconic_control.cfg into the console and it does nothing. I have everything setup perfectly, and I just wanna get this going. Could someone please help me?

 

 

Edit: okay, I got the .cfg file create page open, but now it keeps erroring on me. and I don't know whats up. Here are some screenshots.

Hi,

first of all, you're missing a comma in the first line. I also recommend you to use the same linebreak-/indentation-style as I'm using on the website (it helps a lot in case you're planning on tweaking a bit).

Then in the second screenshot you're trying to execute the configuration file as a program. I'm pretty sure you know what's wrong with that :P

In case you don't, let me quote the guide: 

You can now start the controller with draconic_control start or rc draconic_control start and you're ready to go.

 

You should be ready to go afterwards.

Share this post


Link to post
Share on other sites

I got the program up and running, but as soon as I put in the awakened draconium into the reactor and hit warm up, the computer flashes danger, and I let it "warm up" over night and came back and nothing had changed whatsoever. I don't know whats wrong. I set everything up perfectly. :(

 

Share this post


Link to post
Share on other sites
14 hours ago, Flux_Adept said:

I got the program up and running, but as soon as I put in the awakened draconium into the reactor and hit warm up, the computer flashes danger, and I let it "warm up" over night and came back and nothing had changed whatsoever. I don't know whats wrong. I set everything up perfectly. :(

 

Don't worry about that. It's...uh....normal ^^;

Nothing can go wrong during warm up anyways.

 

EDIT: Do you mean the reactor hasn't properly warmed up? Check your flux gates. The one on the injector should show 1000000RF/t. If it doesn't but the one on the stabilizer does, you've mixed up the gate addresses. Also re-check the gates orientation if the flow looks fine.

Share this post


Link to post
Share on other sites

Both Flux gates show everything correctly. the orientation is fine. it just doesn't warm up. I literally started it, it went into warm up mode. I left it overnight and came back and it was still in warm up mode without the ability to actually start it.

Share this post


Link to post
Share on other sites
24 minutes ago, Flux_Adept said:

Both Flux gates show everything correctly. the orientation is fine. it just doesn't warm up. I literally started it, it went into warm up mode. I left it overnight and came back and it was still in warm up mode without the ability to actually start it.

In this case you don't have any energy stored to actually warm it up OR something is wrong with your power lines and your reactor doesn't get any.

Share this post


Link to post
Share on other sites

I like the monitoring system but i was thinking as a suggestion/ feedback... you could add more touchscreen capabilities to the gui. for example this computercraft script allows me to edit how much output i want directly from the gui. ( https://github.com/acidjazz/drmon ). just a thought :) and yes i know its more complicated than it sounds.

Share this post


Link to post
Share on other sites

Getting GUI Error - Connection Failure

OpenOS 1.6.1
Draconic Control v1.42
SkyFactory3 (1.10.2)
Draconic Evolution - 2.1.6.263
Running on a multiplayer server
All systems are Chunkloaded

Followed this Tutorial https://forum.craftersland.net/topic/22059-open-computers-program-for-draconic-reactor-direwolf20-mc1102/

Running "componants" gives flux gates and reactor at correct address.
draconic_control runOnce says nothing
draconic_control start says nothing
output flux gates are placed in the right direction

 

Share this post


Link to post
Share on other sites

@ClownApocalypse

If you've actually done everything correctly, then I'll have to take a look whether the API changed or not - though I don't think it did.

"Connection Failure" means exactly what you might think it means: It can't contact one of the components. Please double-check whatever you did with https://tenyx.de/draconic_control/. ESPECIALLY the configuration part. Please make sure there is no typo in the keys as well. Also please try to reboot your computer (although I'm pretty sure you already tried that ;) ).

Share this post


Link to post
Share on other sites

Hey, I am running Sky Factory 3 with OC version 1.7.1 and draconic evolution version 2.1.6, i have everything set up as per the images on the draconic control website with the config page as per the image below. Problem is, the computer does not seem to be able to access the input flux gate during warm up (if i start DC before the reactor is completely charged it will never receive power to charge) and after it has been activated, the output flux gate never changes off of 0 RF/t, even if the reactor tops out at 100% energy saturation. I have double checked the addresses like 19 times and they are all correct. "fluxGateOutputAddress" is the gate on the stabilizer and "fluxGateDrainbackAddress" is the gate on the energy injector right? (just making sure i am not crazy) 

Any help on this topic would be excellent! Thanks in advance!

image.thumb.png.2ec29af87db46bda47889063b3248e0c.png

Share this post


Link to post
Share on other sites

I'm having the same problem as a couple of other people on here.  I have run this reactor a bit myself and it works fine.  But when I hook the adapters up to the flux gates, they don't seem to ever change flow rates at all.  The drainback one is set at 1,716RF and the output one is set at 0RF.  I hit charge and let it go once for about an hour and it was charging but of course very very slowly.  I wasn't willing to wait so I shut it down.  Then I hooked another flux gate into the injector to speed up the warm up and see if the computer would control it once it was started which worked... i got it warmed right up but when I started it, it just left the output flow at zero.  I'm not sure where to even start looking for a fix.  I've actually set the components up twice now with the same results.  

Any chance of getting this to work?  

Thanks...  

dsp

Share this post


Link to post
Share on other sites

Hey guys,

sorry for forgetting you ... >_>.

I've just updated my test world to the latest version of DE an OC. Other than the components having their address changed due to the OC update, draconic control still works as intended for me.

Are you, by chance, using any other guide other than my own? If two ppl are having the same issues then maybe said guide has a typo somewhere in the configuration...

Share this post


Link to post
Share on other sites

Hello!

Thank you for putting this all together. i'm finding it fun to play with the configuration file and see what all I can make this thing do.

I am running into a problem however. When using the breeding reactor config as demonstrated on your website, the large exponent seems to cause a problem with how you're calculating the shutdown point in the event of an overtemperature scenario. With that config file the reactor should shut down at 11K due to overtemp, but instead as soon as it hits the limitTemp of 10K it shuts down. I'm guessing there's a floting point number limitation going on, but I can't be sure as I'm not sure how all of this works behind the scenes. Assuming the +10% works in more standard configurations, the exponent is the only thing I can think of that might be causing trouble.

If you could take a look, I'd appreciate it. I'm running draconic_control 1.4.2 and DE 1.12-2.3.8.279

Again, thanks for all the work on this.

Share this post


Link to post
Share on other sites

Hi @Marzolan,

thanks for reporting this issue and for looking into this. :lol:

Unfortunately, it looks like a failsafe / shutdown optimization mechanism is triggered here that I implemented some time after I came up with the breeder. I'll look into making it possible to disable it.

If you want to play with it please have a look at lines 131 - 141 in /usr/lib/draconic_control.lua.

function DraconicController:decideShutdown(reactorInfo)
	if reactorInfo.generationRate == 0 then
		return false
	end
	
	if reactorInfo.fieldDrainRate * self.drainback / reactorInfo.generationRate < 0.7 or reactorInfo.temperature < self.limitTemperature then
		return false
	end
	
	return true
end

You CAN make that function always return false, in which case your reactor SHOULD shut down with roughly 99.51% fuel conversion - and a shutdown time of well over 15 hours. And the whole thing gets extremely scary towards the end ;)

What I'm also curious about is that the reactor works fine using the simulator so I wonder if there's something else that's causing the condition "reactorInfo.fieldDrainRate * self.drainback / reactorInfo.generationRate < 0.7" to become false (starting the reactor with high energy saturation maybe). I need to look into that. If you want a quickfix i suggest you change the function into something like this

function DraconicController:decideShutdown(reactorInfo)
	if reactorInfo.generationRate == 0 then
		return false
	end
	
	local conversion = reactorInfo.fuelConversion / reactorInfo.maxFuelConversion
	if conversion > 0.05 or reactorInfo.fieldDrainRate * self.drainback / reactorInfo.generationRate < 0.7 or reactorInfo.temperature < self.limitTemperature then
		return false
	end
	
	return true
end

Of course making the function always return false does not fix your issue then the floating point thingy might be true. Although I'm pretty sure lua uses doubles, as does my simulator and so does draconic evolution. And floating-point math SHOULD be consistent throughout C++ (simulator), LUA and JAVA.

Share this post


Link to post
Share on other sites

@XyFreak,

I spent some more time with it today and I can confirm that the failsafe section is the culprit. I decided to just modify it by changing

reactorInfo.temperature < self.limitTemperature

 to

reactorInfo.temperature < (self.limitTemperature * 1.1)

to mimic the original intent of having it shutdown at 10% beyond the limitTemperature. Yes, it makes the failsafe slightly less... well... safe, but it work for my needs.

I think I also know why the simulator disagrees with my setup. I have plenty of power to spare, and I'm not concerned about running the reactor at a deficit while playing with the breeder configuration. Even an extreme deficit can be dealt with reasonably well with the amount of power stored in the base being used for this. I didn't want to deal with an explosion while paying though so I bumped the drainback multiplier to 1.5. That appears to be causing the first part of the failsafe line to become false, as you suspected. If I read that failsafe line correctly, you're basically trying to ensure that shield power consumption isn't grosely exceeding reactor production, which is perfectly reasonable for a reactor intended to generate power. So I ran afoul of that by pushing this so hard.

Thanks for looking at it! I'm off and running a very... let's call it exciting... breeder reactor. :)
 

Share this post


Link to post
Share on other sites

@Marzolan , sweet ;)

The other part isn't actually a failsafe but rather a shutdown condition optimization. The condition becomes false as soon as energy generation is going down really heavily. This usually means that the cycle is almost over. As a result the cooldown time will dramatically (!!!) be reduced while maximizing output. As I said... without the optimization in place you'll run into a situation where the reactor is going to take 15hrs to cool down (compared to the <1 hr with it). The change you made essentially makes the function always return false. The actual code that enforces the temperature limit is somewhere else (line 183 and 194-196). If you don't care for the safety part of the function I highly recommend you hardcode some sort of fuel conversion level so your breeder doesn't take ages to cool down ;).

I assume you know this already but let me put it down here anyways: The more chaos is in your reactor, the longer your reactor takes to cool down. And that scales exponentially. So the difference between 61 mb fuel left (that's close to the point of no return btw - i haven't calculated that yet but i think somewhere around 55mb your reactor will be unable to cool down and past that it'll continue to heat up due to its inability to dicipate heat) and .. let's say 120 mb is 15hrs to 3hrs or something.

Anyways - have fun with your breeder :D

Share this post


Link to post
Share on other sites

@XyFreak,

Yes, I have seen what you mean about the excessive cool down time... yikes!

Since a full load of Awakened Draconium can, then, at most product 7 large fragments, which is 87.5% conversion, I just hard coded a 90% conversion shutoff check in for the purposes of using it as a breeder reactor. I might tinker with that a bit more at some point, but for now it lets me keep it moving at a reasonable pace.

Thanks again for your help and advice!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.