Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Forum Connectivity Upgrade Read more... ×
  • 0
Bannon8088

OC causing severe lag

Question

First time trying out opencomputers, it's been in my modpack for a while now but it seemed interesting so I thought I'd give it a try. I build a computer, monitor, drive and components all as needed, start it up and... immediately the game freezes up for seconds at a time as soon as the computer starts up. Sometimes the computer fails to boot with the 'too long without yielding' error as well, because the game hangs for too long while it's loading. As soon as I turn the computer off, everything is fine again. I've tried this with a low tier computer, and with a tier 3 computer fully upgraded. I've tried it with multiblock monitors and single block monitors. Anything I can think of, the game freezes as soon as I turn the computer on. I can't really provide any errors though as it's not really causing any other than the 'Can't keep up!' error in the console.

According to my task manager the system has plenty of ram available and the CPU is only running at 40%. The game is installed on an SSD drive. I'm using a GTX 1070 FE and I just updated Java today.

I'm using Minecraft 1.12.2 with Forge 14.23.4.2759 and OpenComputers 1.7.3.146

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

sounds like a massively bad integration with some other mod. try creating a creative flat world, look at a block on the ground a space or two in front of you, and run `/oc_sc` to spawn a computer and start it up -- just to see if things work at all. you can troubleshoot from there

Share this post


Link to post
Share on other sites
  • 0

Well, I updated the modpack and it has the new version of forge on it now, and I removed every single mod in the pack except for forge, codechickenlib and OpenComputers and it is still causing massive lag. I even removed my resource pack and that didn't help either.

I guess that means that there's something on my computer that it doesn't like. I can't imagine what that could possibly be though.

Everything runs just fine until I actually turn the computer on. The computer sitting in the world while it's turned off is just fine. If the computer doesn't boot because of no EEPROM the display shows an error and there's no lag after that point because the computer isn't running. So it's not the display part of the computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.