Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Zoidbert

AE2 Stock Auto Crafting V1.3 /w Installer

Recommended Posts

This is a simple Applied Energistics 2 Stock AutoCrafting monitor.

With this programm you can say that you want to keep certain items and amounts in stock.

You can specify how many processors you want the program to use.

If ingredients are missing the program will tell you in the message column, but not which ingredients.

If you want to change or delete an item you have to check the box infront of the item name and the press the change or delete button.

The program creates automatically 2 config files, 1 for the items and the other one for some other values (at this time only max cpu usage is stored in this file).

 

V1.3:

https://pastebin.com/326Sh9Xe << Installer for AutoCrafting and GUI Lib                  (pastebin get 326Sh9Xe AE2AutoStockInstaller.lua)                

Changelog:

  • Completely overwritten Code
  • Added GUI for better editing of Crafting List
  • Added Installer (Installer will set Startup to AE2 Auto Stock tool)

V1.2:

not Published

V1.1:

https://pastebin.com/wDup161T

Changelog:

  • Added more errors: No Recipe (if recipe is not in network) and All Cpus busy (if players/programs request/s occupied all cpus)

V1.0:

https://pastebin.com/JC3WewzK

 

Have fun and enjoy...

 

Sorry for my bad english... :rolleyes:

AE2AutoStock_Main.thumb.PNG.529bcc21f27a3c6b6822975731c9e8db.PNG

AE2AutoStock_AddItem.thumb.PNG.d200547c702a721f19ca5e0cb3d214a3.PNG

 

Edited by Zoidbert
Update to V1.3

Share this post


Link to post
Share on other sites

there are a few problems with this app 1st it crashes when you try to delete a entry 2nd it is unclear what you mean by name I have tried just about any combination of names and none works it seams otherwise the program I have been looking for 4 ever

2019-02-02_00.54.27.png

Share this post


Link to post
Share on other sites

That bug is on line 233, as it calls saveItems instead of SaveItems (note the initial letter being lowercase). Simple fix.

 

Also: from looking at the code, I think the 'name' parameter is the registry name of the item, e.g. minecraft:torch or chisel:chisel_diamond. You can use F3+H to see those names.

Share this post


Link to post
Share on other sites
15 hours ago, BrisingrAerowing said:

That bug is on line 233, as it calls saveItems instead of SaveItems (note the initial letter being lowercase). Simple fix.

 

Also: from looking at the code, I think the 'name' parameter is the registry name of the item, e.g. minecraft:torch or chisel:chisel_diamond. You can use F3+H to see those names.

Thank you both, i will fix this bug in next version.

14 hours ago, duz_holger said:

still no joy even with registry name raw name and a new error

 

 

2019-02-02_06.32.15.png

2019-02-02_06.33.30.png

2019-02-02_06.38.50.png

You have to insert the item name in all lowercase i think... here is an example (fluixcrystal from applied energistics):

number 1 is the registered name of the item in minecraft and number 2 is the item damage (metadata)....

some modders use only one registered name for all their ingots etc... the damage specifies then what ingot it is...

itemInfo.PNG.e53c0b26803397ab9bb73563c3dffe9e.PNG

addItem.PNG.7d528a4a8391172d392e80b806875809.PNG

 

the 2nd error i couldn reproduce... sorry...

 

Share this post


Link to post
Share on other sites

total noob here how do you attach the computer to the ae2 system please?

Ok found out how to do it.  But now after I run the installer program it says it installed then auto reboots.  But when it is booted I have the gui background but got the home prompt on screen

 

2019-02-04_19_22_51.thumb.png.2cd76a7ab50fda6d69276d84890b6730.png

Edited by grazazel
worked out original answer but got a new problem

Share this post


Link to post
Share on other sites
On 2/3/2019 at 1:07 PM, duz_holger said:

still no luck on my end :( don't know why

I forgot to mention that you have to have the mod Computronics 1.12.1-1.6.5 installed in the modpack. Maybe this is the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.