Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • 0
DeBrates

Redstone Card Issues/Bug

Question

I'm having trouble with the redstone card. Whatever I do I can't seem to get any redstone output. My main goal is bundled output in a separate program, but I wrote this test program to see if any redstone output would function. From what I've seen this looks valid to me. Is there any reason this code wouldn't work? Program is just intended to output on the left side and write the strength on the monitor.

I've tried both tiers of redstone cards, and tried all side aliases such as sides.left and sides.east.

Edit: Redstone i/o works but I don't see a reason the redstone card wouldn't unless it/something is bugged.

local component = require("component")
local sides = require("sides")
local rs = component.redstone
local mon = component.gpu
mon.setResolution(58,18)

rs.setOutput(sides.left, 15)

local strength = rs.getInput(sides.left)
mon.set(1,7, tostring(strength))

 

Any help is appreciated! Thanks!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

didnt test it but if im not wrong you have to supply the redstone signal from another block, did you try with a redstone torch (+dust) next to your computer?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.